Официальный форум ООО НПП  

Вернуться   Официальный форум ООО НПП "ТЕНЕТ" > Технические вопросы > Настройки роутеров

Ответ
 
Опции темы Опции просмотра
Старый 22.01.2013, 00:14 Вверх   #11
engel
Пользователь
 
Сообщений: 36
Репутация: 10
По умолчанию

самое главное это то что при прошивке на опенврт из-под последних версий прошивки не включаеться ван-порт(тп-линковцы переработали лоадер и в оригинальной прошивке ван включаеться после ее загрузки а не до как было на более ранних версиях) поэтому нужно сначала даунгрейдиться на старую версию (которой кстати уже нет на офсайте, могу скинуть если нужно). дальше после того как прошились то настройте сначала вай-фай и лан, а потом уже ван-коннекшн во вкладке ньютворк и не закрывая браузер подключитесь по ssh к роутеру и в терминале введите следующее

uci set network.wan.macaddr="11:22:33:aa:bb:cc"

где 11:22:33:aa:bb:cc ваш мак адрес

вернитесь в браузер и обновите страницу, вы должны увидеть в правом верхнем углу unsaved changes: 1 щелкните по этой надписи и нажмите save and apply после чего перезагрузите роутер (через тот же браузер а не отключая от питания).
и все должно подключиться
engel вне форума   Ответить с цитированием
Старый 22.01.2013, 20:25 Вверх   #12
engel
Пользователь
 
Сообщений: 36
Репутация: 10
По умолчанию

только не забудьте сменить мак адрес сетевой карты, а то иначе если вы от роутера протянете шнур к пк то инета не будет, будет только вай-фай
engel вне форума   Ответить с цитированием
Старый 04.02.2013, 20:41 Вверх   #13
Ryogo
Новичок
 
Аватар для Ryogo
 
Сообщений: 5
Репутация: 10
По умолчанию

Настроил OpenWRT Attitude Adjustment 12.09 RC1 на TP-Link TL-1043ND:
Dual PPPOE (для локальных ресурсов) + UDPXY (для IPTV).
Если есть вопросы - задавайте.
P.S.: не осилил настройку IGMProxy.
Ryogo вне форума   Ответить с цитированием
Старый 21.10.2013, 08:01 Вверх   #14
Neo
Новичок
 
Сообщений: 14
Репутация: 10
По умолчанию

etc/config/igmpproxy:
Код:
config igmpproxy
	option quickleave 1

config phyint
	option network local #при Dual Access наименование DHCP соединения к провайдеру
	option direction upstream
	list altnet 192.168.252.0/24
	list altnet 192.168.229.0/24

config phyint
	option network br-lan
	option direction downstream

config phyint
	option network pppoe-wan
	option direction disabled

config phyint
	option network loopback
	option direction disabled
в /etc/config/firewall добавить:
Код:
config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'
в /etc/config/network в раздел lan добавить:
Код:
option igmp_snooping '1'
Neo вне форума   Ответить с цитированием
Старый 29.10.2013, 14:19 Вверх   #15
Den-i
Новичок
 
Сообщений: 1
Репутация: 10
По умолчанию Не работает IPTV пере прошит OpenWrt

Цитата:
Сообщение от Neo Посмотреть сообщение
etc/config/igmpproxy:
Код:
config igmpproxy
	option quickleave 1

config phyint
	option network local #при Dual Access наименование DHCP соединения к провайдеру
	option direction upstream
	list altnet 192.168.252.0/24
	list altnet 192.168.229.0/24

config phyint
	option network br-lan
	option direction downstream

config phyint
	option network pppoe-wan
	option direction disabled

config phyint
	option network loopback
	option direction disabled
в /etc/config/firewall добавить:
Код:
config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'
в /etc/config/network в раздел lan добавить:
Код:
option igmp_snooping '1'
У меня Router TP-Link Mod. TL-WR1043ND пере прошит OpenWrt
Использую плеер IP-TV Player адрес теле программ
http://tv.tenet.ua/iptv.m3u
Пишет при обновлении «Ошибка при обновлении теле программ»
Также находил мануал по настройке IGMP proxy на сайте
http://wiki.openwrt.org/ru/doc/howto/udp_multicast

Там написано что . Если в файле конфигурации не будет хватать сетей, то вы увидите в логе, что-то типа: «Warn: The source address 10.254.16.66 for group 233.32.240.222, is not in any valid net for upstream VIF». Таким образом вы узнаете широковещательный адрес вашего провайдера и сможете добавить необходимую подсеть в файл конфигурации /etc/config/igmpproxy.

Я так думаю что не правильно указан широковещательный адрес ! Подскажите кто знает как правильно настроить!!!!

Neo а ты проверял у тебя работает?!

Спасибо жду ответа!
Den-i вне форума   Ответить с цитированием
Старый 03.02.2015, 23:36 Вверх   #16
RaZario
Новичок
 
Аватар для RaZario
 
Сообщений: 5
Репутация: 10
Unhappy OpenWRT + IPTV

Всем привет.
Кто может скинуть конфиги для подключения IPTV на OpenWRT (Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530) ), установлена на Dir-300.

Под утилиты udpxy и igmpproxy!
Желательно конфиг самой утилиты и правила firewall-а для неё.

З.Ы.: я уже долго бьюсь, чтоб всё это завести, но безрезультатно. На телеке постоянно выдаёт буферизацию, и ни чего не показывает (кроме как программы передачь на данном канале). На ноуте IPTV показывало (через igmpproxy и сайт "Комфортное ТВ").

Телевизор LG 39vb650 (WebOS) виджеты установлены "Комфортное ТВ" и SS-IPTV.

З.Ы.Ы.: делал по стандарту ТЫЦ, не получилось.

З.Ы.Ы.Ы.: на каком канале из плей листа можно всё проверить? (в данный момент от IPTV пакета отказался, я обычно проверял по каналу TeNeT )
RaZario вне форума   Ответить с цитированием
Старый 09.02.2015, 20:17 Вверх   #17
leshiy_odessa
Частый пользователь
 
Сообщений: 576
Репутация: 51
По умолчанию

Цитата:
Сообщение от RaZario Посмотреть сообщение
Всем привет.
Кто может скинуть конфиги для подключения IPTV на OpenWRT (Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530) ), установлена на Dir-300.
Я надеюсь что DUAL ACCESS настроен ? Тогда поехали.
У меня локальный интерфейс назван "WAN", следовательно ниже в конфигах именно он, а не PPPoE.

1. Получаем маршруты по DHCP.
etc\config\network
Код:
config interface 'wan'
	option reqopts 'staticroutes msstaticroutes'
2. Добавляем маршрут :
etc\config\network
Код:
config route
	option interface 'wan'
	option target '224.0.0.0'
	option netmask '240.0.0.0'
	option gateway '0.0.0.0'
3. etc/config/igmpproxy

Код:
config phyint
        option network wan
        option direction upstream
        list altnet 192.168.252.0/24
        list altnet 192.168.252.0/24
        list altnet 224.0.0.0
Все остальное, строго по инструкции. ДОЛЖНО ВСЕ РАБОТАТЬ.

Последний раз редактировалось leshiy_odessa; 09.02.2015 в 20:25.
leshiy_odessa вне форума   Ответить с цитированием
Старый 17.02.2015, 20:20 Вверх   #18
xasvit
Новичок
 
Сообщений: 8
Репутация: 10
По умолчанию

Цитата:
Сообщение от leshiy_odessa Посмотреть сообщение
Я надеюсь что DUAL ACCESS настроен ?

Все остальное, строго по инструкции. ДОЛЖНО ВСЕ РАБОТАТЬ.
Роутер Tp-Link 841v7----(0.12+svn-r10530)_14.07 - не работает.
Вернее, не работает только через igmpproxy. Неделю уже и так, и сяк, никак не получается. Где-то косячу, но вот где?
Через udpxy всё получилось, но не очень устраивает, что каналы переключаются дольше, чем обычно (где-то 4 сек). Хочется всё-таки попробовать запустить через igmpproxy.
xasvit вне форума   Ответить с цитированием
Старый 18.02.2015, 11:28 Вверх   #19
xasvit
Новичок
 
Сообщений: 8
Репутация: 10
По умолчанию

Цитата:
Сообщение от leshiy_odessa Посмотреть сообщение
Я надеюсь что DUAL ACCESS настроен ? Тогда поехали...

Все остальное, строго по инструкции. ДОЛЖНО ВСЕ РАБОТАТЬ.
Спасибо за ссылки. Почти получилось. Через udpxy заработало, но как-то долго(4-5 сек) переключает каналы. А через igmpproxy никак не получается, где-то косячок, но моих знаний "поймать" его не получается.
Роутер Тп-Линк 841 в7.
xasvit вне форума   Ответить с цитированием
Старый 25.02.2015, 15:45 Вверх   #20
leshiy_odessa
Частый пользователь
 
Сообщений: 576
Репутация: 51
По умолчанию

Цитата:
Сообщение от xasvit Посмотреть сообщение
Через udpxy заработало, но как-то долго(4-5 сек) переключает каналы.
Долгое переключение это нормально. Напрямую зависит от мощности роутера. Можно конечно в IpTvPlayer уменьшить кеш до 100 мс.

Цитата:
Сообщение от xasvit Посмотреть сообщение
А через igmpproxy никак не получается, где-то косячок, но моих знаний "поймать" его не получается.
list altnet 192.168.252.0/24
list altnet 192.168.229.0/24


Есть инструкция и по ней все настраивается идеально.



Если вы смотрите IPTV через Wi-Fi, то igmpproxy вреден и необходим udpxy.
Если вы смотрите по кабелю, то лучше конечно igmpproxy.

Последний раз редактировалось leshiy_odessa; 25.02.2015 в 15:50.
leshiy_odessa вне форума   Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Часовой пояс GMT +2, время: 10:37.


Powered by vBulletin®
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.