Официальный форум ООО НПП  

Вернуться   Официальный форум ООО НПП "ТЕНЕТ" > Технические вопросы > Настройки роутеров

Ответ
 
Опции темы Опции просмотра
Старый 19.05.2020, 15:47 Вверх   #201
Helper
Частый пользователь
 
Аватар для Helper
 
Сообщений: 9,165
Репутация: 87
По умолчанию

Цитата:
Сообщение от panaceya Посмотреть сообщение
Когда будет реализовано?
В ближайшее время - маловероятно.

Цитата:
Да. забыли написать еще одно решение - можно сменить провайдера.
В сети других провайдеров количество телеканалов и сервисов TENET-TV меньше, чем в сети TENET.
__________________
Техподдержка круглосуточно - (048/050/093/098) 730 53 00, telegram-чат - https://t.me/tenet_support_bot
Helper вне форума   Ответить с цитированием
Старый 21.04.2021, 18:22 Вверх   #202
Viktor_od
Новичок
 
Сообщений: 29
Репутация: 9
Thumbs up Настройка IPTV на Mikrotik Router Board RB951G-2HnD

Для примера настройки IPTV я взял Mikrotik RB951G-2HnD.
Не совсем домашний роутер, конечно, но настройка на других устройствах принципиально ничем отличаться не будет.



ОБНОВЛЕНИЕ ROUTEROS (ДОБАВЛЕНИЕ ПАКЕТА ДЛЯ IPTV)
Обновление необходимо для того, чтобы установить дополнительный пакет для IPTV.
Заходим на сайт Mikrotik, ищем в списках линейку вашей модели и скачиваем последнюю версию прошивки для нее.
Обратите внимание, выбираем не прошивку с основными пакетами (main), а с дополнительными (extra):


Открываем WinBox, заходим на роутер (советуем заходить изначально по мак-адресу, это облегчит дальнейший процесс настройки).
Чтобы обновить ПО роутера, идем в меню Files.
Открываем его и перетаскиваем в окно Files наш скачанный файл из распакованного архива под названием multicast-x.xx-mipsbe.npk.


Пакет добавлен и после этого мы перезагружаем оборудование в меню System – Reboot.
Роутер перезагрузится и обновит прошивку.
Процесс может занять до 5-ти минут.
Питание в это время отключать не следует!
После перезагрузки открываем System - Packages и смотрим, появился ли модуль multicast.


Если таковой имеется, значит, вы все сделали правильно.

ВКЛЮЧАЕМ ЛОКАЛКУ ТЕНЕТа
Нет локалки ТЕНЕТа — нет IPTV.
Идете в IP —> DHCP Client —> [ваше подключение] — и ставите "yes" - Add Default Route и жмёте Enabled.
В роутах должно появится приблизительно такое.
Только вместо 10.9.47.250 у вас будет ваш шлюз.



НАСТРОЙКА IGMP PROXY
Открываем в меню MikroTik Routing - IGMP Proxy.
Нам нужно добавить новый интерфейс, для этого кликаем на плюс (как указано на скрине).


В новом интерфейсе, в поле Interface выбираем порт, по которому у нас поступает интернет, в нашем случае это ether1 и устанавливаем галочку галочку Upstream, как на скриншоте:



В поле Interface выбираем WAN порт по которому к нам приходит интернет.
В поле Alternative Subnets указываем подсеть с которой идет вещание IPTV.
Указать 0.0.0.0/0, но лучше уточнить у поставщика услуг.
Так же ставим галочку Upstream и нажимаем OK.

Создаем еще один интерфейс, кликая по синему плюсу, но теперь мы не ставим галочку напротив Upstream и при этом выбираем порт тот, на который мы будем перебрасывать IPTV - то есть тот, к которому подключено устройство, на котором мы будем смотреть IPTV.
В нашем случае это bridge, потому что к нему подключен стационарный ПК.
То есть в первом случае мы указывали порт, куда входят данные, а теперь – откуда выходят.


После мы нажимаем кнопку Settings и ставим галочку напротив Quick Leave.
Делаем мы это для того, чтобы иметь возможность быстро переключаться между каналами.



НАСТРОЙКА FIREWALL
Настраиваем наш Firewall, который не пропускает IPTV на данный момент, для этого мы создаем новый терминал, нажимаем New Terminal и открывается вот такое окно:


Теперь мы должны выполнить в этой консоли несколько команд:
Цитата:
/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether1 protocol=igmp
/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether1 protocol=udp
/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp
1234 – порт неофициально зарегистрированный для передачи потокового видео и IPTV ether1 - это интерфейс, на который приходит IPTV от провайдера.
Далее нужно в меню IP выбрать пункт Firewall и перейти на вкладку Filter Rules.
Мы создали исключающие правила, и чтобы они работали, они должны быть выше запрещающих.
Перетягиваем их вверх с помощью мыши.



Осталось только проверить работоспособность нашей конфигурации.
Я использовал для этого IPTV плеер, предварительно загрузив лист каналов для нашего провайдера (TENET) в настройках плеера.

Viktor_od вне форума   Ответить с цитированием
Старый 22.04.2021, 01:55 Вверх   #203
Skyworker
Пользователь
 
Сообщений: 33
Репутация: 14
По умолчанию

Цитата:
Сообщение от Viktor_od Посмотреть сообщение
Для примера настройки IPTV я взял Mikrotik RB951G-2HnD....
Для того, чтобы multicast не сыпался на все интерфейсы, которые включены в bridge, надо в его настройках включить IGMP Snooping (настройка bridge, закладка General, выбрать галочку внизу IGMP Snooping, после появится дополнительная закладка с аналогичным названием, там выбрать вторую версию протокола). Это нормально работает на версии ROS 6.48.2

В поле Alternative Subnets указать эти сети: 10.0.0.0/8 и 192.168.0.0/16

Чтобы на Wi-Fi нормально работало IPTV надо в настройках Wi-Fi интерфейса включить Multicast Helper: full и стояла галочка Multicast Buffering (хотя по Wi-Fi лучше его не смотреть)

Это правило лишнее:
/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether1 protocol=udp

Правда на моём Hap Lite IPTV иногда сыпется, когда интернетовского трафика на самом роутере более 20-30 Mbit(хотя по статистике роутера ни drop, ни errors пакетов нету), но тут думаю сам роутер не слишком производительный, как говорится hap ac2 в помощь.
Skyworker вне форума   Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Часовой пояс GMT +2, время: 20:29.


Powered by vBulletin®
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.