Официальный форум ООО НПП  

Вернуться   Официальный форум ООО НПП "ТЕНЕТ" > Технические вопросы > Настройки роутеров

Ответ
 
Опции темы Опции просмотра
Старый 15.09.2015, 14:55 Вверх   #31
leshiy_odessa
Частый пользователь
 
Сообщений: 575
Репутация: 51
По умолчанию

Цитата:
Сообщение от Lichtenshtein Посмотреть сообщение
leshiy_odessa, вроде что-то заработало

Сделал как вы и написали - переименовал wan в pppoe в /etc/config/network, соответствующих правилах в /etc/config/firewall и добавил локальный интерфейс wan, попутно прописав там же route.
НЕТ!!!!!!!!!!!!!! НУ где я такое писал. WAN это локальный интерфейс, а PPPoE это для интернета. Это два разных интерфейса. Переименовывать нужно local в WAN.

И маршруты у вас выглядят неправильно, должно быть так :
где 10.0.26.250 будет другим, это ваш шлюз.

Код HTML:
tenet_pppoe 	0.0.0.0/0 	195.139.80.1 	0
wan 	0.0.0.0/0 	10.0.26.250 	50
wan 	10.0.0.0/8 	10.0.26.250 	50
wan 	10.0.24.0/24 	0.0.0.0 	50
lan 	192.168.1.0/24 	0.0.0.0 	0
wan 	195.138.68.88/29 	10.0.26.250 	50
wan 	195.138.70.208/28 	10.0.26.250 	50
wan 	195.138.78.64/28 	10.0.26.250 	50
wan 	195.138.80.24 	10.0.26.250 	50
wan 	195.138.80.40 	10.0.26.250 	50
wan 	195.138.80.43 	10.0.26.250 	50
wan 	195.138.80.50 	10.0.26.250 	50
wan 	195.138.80.54 	10.0.26.250 	50
wan 	195.138.80.83 	10.0.26.250 	50
wan 	195.138.80.84/30 	10.0.26.250 	50
tenet_pppoe 	195.139.80.1 	0.0.0.0 	0
wan 	224.0.0.0/4 	0.0.0.0

Так, все, это в последний раз, вот вам рабочие конфиги, только сетевые интерфейсы у вас будут другими — eth0.1 —> eth1
Не копируйте бездумно, а сделайте у себя по аналогии.

/etc/config/network

Код:
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '172.17.1.1' <— IP роутера у вас 192.168.1.1
	option netmask '255.255.255.0'

config interface 'wan' <— ЛОКАЛКА ТЕНЕТ
	option ifname 'eth0.2'
	option proto 'dhcp'
	option metric '50'
	option reqopts 'staticroutes msstaticroutes'
	option delegate '0'

config interface 'tenet_pppoe' <— ИНТЕРНЕТ
	option ifname 'eth0.2'
	option proto 'pppoe'
	option delegate '0'
	option username 'логин'
	option password 'пароль'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

config route
	option interface 'wan'
	option target '224.0.0.0' <— маршрут под IPTV
	option netmask '240.0.0.0'
	option gateway '0.0.0.0'

/etc/config/firewall

Код:
config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan tenet_pppoe'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-UDPXY'
	option src 'wan'
	option proto 'udp'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

config redirect
	option name 'Torrent'
	option target 'DNAT'
	option src 'wan'
	option dest 'lan'
	option proto 'tcp udp'
	option dest_ip '172.17.1.2'
	option src_dport '17171'
	option dest_port '17171'

config rule
	option name 'udpxy status (4022)'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'tcp udp'
	option dest_port '4022'
	option enabled '0'

config rule
	option name 'udpxy status (http port 80)'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'tcp'
	option dest_port '80'
	option enabled '0'
/etc/config/dhcp

Код:
config dhcp 'lan'
	option interface 'lan'
	option leasetime '24h'
	option start '2'
	option limit '254'
------  подключенные устройства получают от DHCP сервера DNS и ШЛЮЗ — 192.168.1.1
	list dhcp_option '6,192.168.1.1' 
	list dhcp_option '3,192.168.1.1'

Последний раз редактировалось leshiy_odessa; 15.09.2015 в 15:20.
leshiy_odessa вне форума   Ответить с цитированием
Старый 15.09.2015, 15:08 Вверх   #32
leshiy_odessa
Частый пользователь
 
Сообщений: 575
Репутация: 51
По умолчанию

Цитата:
Сообщение от Lichtenshtein Посмотреть сообщение
Единственное, что озадачило - перестало работать IP-TV через udpxy
Если вы не устанавливали udpxy, то его и нет. Если вы его установили, но он перестал работать, то нужно разбираться. Для мобильных устройств сильно лучше udpxy, потому что IGMP Proxy (мультикаст) очень сильно забивает радиоканал.

Запретить мультикаст пакетам идти на WLAN
/etc/config/igmpproxy
Код:
config phyint
    option network wlan0
    option direction disabled
leshiy_odessa вне форума   Ответить с цитированием
Старый 16.09.2015, 02:53 Вверх   #33
Lichtenshtein
Новичок
 
Сообщений: 4
Репутация: 10
По умолчанию

leshiy_odessa, приложу конфиги, просто в заблуждение ввёл вас...

Код:
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2d:cb3a:f7b8::/48'

config interface 'lan'
	option ifname 'eth0'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option macaddr 'bb:a0:a0:9f:a9:9b'
	option dns '4.2.2.1 8.8.4.4 4.2.2.2 208.67.222.222'

config interface 'pppoe' # интернет wan переименовал в pppoe
	option ifname 'eth1'
	option proto 'pppoe'
	option username 'login'
	option password 'password'
	option keepalive '3 5'
	option delegate '0'
	option peerdns '0'
	option macaddr 'bb:a0:a0:9f:a9:9b'
	option dns '4.2.2.1 8.8.4.4 4.2.2.2 208.67.222.222'

config interface 'wan' # local переименовал в wan; локалка провайдера
	option proto 'dhcp'
	option ifname 'eth1'
	option peerdns '0'
	option metric '50'
	option reqopts 'staticroutes msstaticroutes'
	option delegate '0'

config route # прописал маршрут
	option interface 'wan'
	option target '224.0.0.0'
	option netmask '240.0.0.0'
	option gateway '0.0.0.0'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'
Поправил у себя firewall в соответствии с вашим:

Код:
config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option block_static_ip_mismatches '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
        option name 'pppoe'
        list network 'pppoe'
        list network 'wan6'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan pppoe'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'pppoe'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'pppoe'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'pppoe'
	option proto 'udp'
	option src_ip 'fe80::/10'
	option src_port '547'
	option dest_ip 'fe80::/10'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'pppoe'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'pppoe'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPTV-IGMPROXY'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option target 'ACCEPT'

config rule	
	option name 'Allow-IPTV-UDPXY'
	option src 'wan'
	option proto 'udp'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

config rule
	option name 'udpxy status (4022)'
	option target 'ACCEPT'
	option src 'wan'
	option proto 'tcp udp'
	option dest_port '4022'
	option enabled '0'

config include
	option path '/etc/firewall.user'
	option reload '1'

config include
	option type 'script'
	option path '/usr/lib/gargoyle_firewall_util/gargoyle_additions.firewall'
	option family 'IPv4'
	option reload '1'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'

config include 'openvpn_include_file'
	option path '/etc/openvpn.firewall'
	option reload '1'

config include 'tor_include_file'
	option path '/etc/tor.firewall'
	option reload '1'
Теперь заработал и udpxy. Сетевые маршруты, похоже, остались прежними, не понимаю что с ними не так..



p.s. не моё всё это. Работает и ладно. Извините, что отнял время и спасибо за помощь.
Lichtenshtein вне форума   Ответить с цитированием
Старый 16.09.2015, 14:58 Вверх   #34
leshiy_odessa
Частый пользователь
 
Сообщений: 575
Репутация: 51
По умолчанию

Цитата:
Сообщение от Lichtenshtein Посмотреть сообщение
Сетевые маршруты, похоже, остались прежними, не понимаю что с ними не так..
Понимаете старые пользователи знают что если у вас локальный IP 10.168.79.XX, то ваш шлюз заканчивается на .250 — 10.168.79.250

А у вас почему то шлюз 10.168.79.1 и еще откуда то выплывает 10.168.79.2. Это видимо приставка. Как предположение у вас какой то особенный дом, особенное подключение или ТЕНЕТ уже делает всё по новому.
Это означает что нужно держать всю эту информацию в голове, потому что в некоторых случаях информация от других пользователей по настройке может вам не подойти.

Учитывая размер "системного отдела" я могу себе представить весь тот зоопарк оборудования.
leshiy_odessa вне форума   Ответить с цитированием
Старый 06.01.2016, 01:34 Вверх   #35
s-drumer
Новичок
 
Сообщений: 25
Репутация: 11
По умолчанию

Баг там вообщем-то один, и давно.
http://forum.mclaut.com/viewtopic.php?p=45991
Не удивительно что так много проблем вылазит.

Остальное делать как описано тут
https://wiki.openwrt.org/ru/doc/howto/udp_multicast

За исключением что wan не переименовывать ,не удалять, и оставить на нём dhcp.
pppoe делать дополнительным соединением.
s-drumer вне форума   Ответить с цитированием
Старый 20.01.2016, 18:38 Вверх   #36
Skyworker
Пользователь
 
Сообщений: 32
Репутация: 14
По умолчанию

Цитата:
Сообщение от s-drumer Посмотреть сообщение
Баг там вообщем-то один, и давно.
http://forum.mclaut.com/viewtopic.php?p=45991
Не удивительно что так много проблем вылазит.

Остальное делать как описано тут
https://wiki.openwrt.org/ru/doc/howto/udp_multicast

За исключением что wan не переименовывать ,не удалять, и оставить на нём dhcp.
pppoe делать дополнительным соединением.
"Смешались в кучу кони, люди,
И залпы тысячи орудий
Слились в протяжный вой…"
Большинство багов и лагов происходят от незнания и непонимания происходящего. В той ссылке, что вы дали, интерфейс получал адрес на 600 секунд, т.е. 10 минут. Каждые 10 минут igmpproxy перезапускался, ну так он устроен - получать данные с одного интерфейса и отправлять на другой. А когда параметры одного интерфейса меняются он конечно же перенастраивается . У ТеНеТ подключают клиентов по PPPoE, где внешний адрес динамически меняется. Так же есть простое подключение, по DHCP, где адрес обновляется намного реже, чем 10 минут. Так что перезапуск igmpproxy это вещь редкая. Из опыта использования OpenWrt могу сказать, что igmpproxy у меня работает исключительно стабильно и проблем с ним нету.
Для нормальной работы igmpproxy надо всего лишь прописать интерфейс с которого приходит iptv, интерфейс на который уходит iptv и сеть, с которой идёт вещание, так же указать интерфейсы, которые в передаче iptv не участвуют. Тенет ведёт вещание iptv через свою локальную сеть(это там, где подключение осуществляется через DHCP), но можно получать iptv и через жпоу , т.е. через PPPoE, тогда iptv будет проходить через интернет соединение и занимать часть входящего потока, что приведет к снижению входящей скорости интернета. А может и наоборот быть - слишком широкий канал iptv или несколько одновременно просматриваемых каналов не смогут целиком войти в ширину вашего интернет соединения и тогда iptv будет лагать.
Как эти интерфейсы будут называться wan, lan, tumba-umba и т.д. не важно, важно чтобы эти интерфейсы так же назывались в системе.
Вот пример моего конфига igmpproxy
Код:
config igmpproxy
        option quickleave 1

config phyint
        option network localtenet
        option direction upstream
        list altnet 192.168.229.0/24
        list altnet 192.168.252.0/24

config phyint
        option network lan
        option direction downstream

config phyint
        option network loopback
        option direction disabled

config phyint
        option network wan
        option direction disabled
где сеть localtenet у меня локальная сеть Тенет(это там, где адрес дают через DHCP,захотелось мне её так назвать), lan - моя локальная сеть, wan - это подключение к интернету PPPoE(где вводить логин и пароль)
Указание upstream говорит, что это интерфейс с которого приходит iptv и идёт перечисление сетей, с которых идёт вещание list altnet 192.168.229.0/24 и list altnet 192.168.252.0/24;
Указание downstream говорит, что это интерфейс на который уходит iptv;
Указание disabled - это интерфейсы, которые в передаче iptv не участвуют.
Вот пример настройки моих соединений
Код:
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'XXXX:XXXX:XXXX::/48'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'derlogin'
        option password 'derparol'
        option macaddr 'XX:XX:XX:XX:XX:XX'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'localtenet'
        option proto 'dhcp'
        option ifname 'eth1'
        option defaultroute '0'
        option macaddr 'XX:XX:XX:XX:XX:XX'
        option reqopts 'staticroutes'

config route
        option interface 'lan'
        option target '192.168.0.0'
        option netmask '255.255.255.0'
        option gateway '192.168.1.10'
Некоторые данные были изменены.
Часть конфига firewall
Код:
config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 localtenet'
config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPTV-IGMPPROXY'
        option src 'wan'
        option proto 'udp'
        option dest 'lan'
        option dest_ip '224.0.0.0/4'
        option target 'ACCEPT'
Здесь следует понимать, что строка option src 'wan' это не указание интерфейса, а указание зоны, определённой ранее, куда входят интерфейсы wan wan6 localtenet
Код:
config zone
        option name 'wan'
	.
	.
	option network 'wan wan6 localtenet'
Запуск демона igmpproxy я настроил таким образом, чтобы он запускался, когда подымается интерфейс, с которого приходит iptv

Я в папке /etc/hotplug.d/iface/ положил файл 70-igmpproxy с таким содержанием

Код:
#!/bin/sh
#This script run and stop igmpproxy

[ "$ACTION" = ifup -a "$INTERFACE" = localtenet ] && /etc/init.d/igmpproxy start

[ "$ACTION" = ifdown -a "$INTERFACE" = localtenet ] && /etc/init.d/igmpproxy stop
т.е. при поднятии интерфейса localtenet выполняется скрипт /etc/init.d/igmpproxy start
а при падении интерфейса localtenet выполняется скрипт /etc/init.d/igmpproxy stop



А Ваша
Цитата:
За исключением что wan не переименовывать ,не удалять, и оставить на нём dhcp.
pppoe делать дополнительным соединением.
мне напомнила другую фразу
Цитата:
....а просто маэстро Воланд в высокой степени владеет техникой фокуса, что и будет видно из самой интересной части, то есть разоблачения этой техники, а так как мы все как один и за технику, и за ее разоблачение, то попросим господина Воланда!
Произнеся всю эту ахинею, Бенгальский сцепил обе руки ладонь к ладони и приветственно замахал ими в прорез занавеса, от чего тот, тихо шумя, и разошелся в стороны.
Skyworker вне форума   Ответить с цитированием
Старый 21.01.2016, 21:40 Вверх   #37
leshiy_odessa
Частый пользователь
 
Сообщений: 575
Репутация: 51
По умолчанию

Цитата:
Сообщение от Skyworker Посмотреть сообщение
Вот пример моего конфига igmpproxy

Вот самое главное вы не рубанули, а именно Wi-Fi

Код:
config phyint
    option network wlan0
    option direction disabled

Чтобы multicast-трафик не забивал Wi-Fi, надо включить IGMP snooping. Для этого в /etc/config/network в секции config interface 'lan' добавляем:

option igmp_snooping '1'


Ну и чтобы было совсем идеально можно еще добавить DHCP Option 121 и DHCP Option 249.


Код:
config interface 'localtenet'
	option reqopts 'staticroutes msstaticroutes'
И не понятно что там делает — option defaultroute '0'
leshiy_odessa вне форума   Ответить с цитированием
Старый 22.01.2016, 00:08 Вверх   #38
Skyworker
Пользователь
 
Сообщений: 32
Репутация: 14
По умолчанию

Да, вы правы, про IGMP snooping я не упомянул, но он у меня включен. Я просто действовал как в инструкции к OpenWrt было описано:
Код:
Проверьте, что поддержка «IGMP snooping» присутствует в вашей прошивке OpenWrt и включена!

Выполните команду:

# cat /sys/devices/virtual/net/br-lan/bridge/multicast_snooping
Если команда выдаст сообщение содержащие «No such file or directory», то прошивка скомпилирована без поддержки «IGMP snooping» и просмотр IPTV затормозит вашу беспроводную сеть.

Если файл существует, то вывод команды выдаст либо «1», либо «0». Если выдается «1», то ничего делать не надо, а если «0», то для включения «IGMP snooping» в файл /etc/config/network, в конфигурации интерфейса «lan», необходимо добавить строку:

option igmp_snooping 1
У меня выдало 1 и я забыл про это проблему.

А вот DHCP Option 121 и DHCP Option 249. - я этого не понимаю.

Когда я локалку Тенета настраивал, то я прописал option reqopts 'staticroutes'. Насколько я помню стока option reqopts передаёт DHCP клиенту список дополнительных параметров, а передаваемый параметр staticroutes в свою очередь говорит получить от DHCP сервера список маршрутов и добавить их в таблицу маршрутизации. Я с этим параметром запускал клиента, потом проверял таблицу маршрутизации - всё нормально, маршруты от Тенет получались и добавлялись. Вот что делает опция msstaticroutes я не знаю. А добавлять то, чего не знаю и при этом маршруты Тенета у меня по DHCP принимаются и добавляются, я как-то не горю желанием.

Опцию option defaultroute '0' я руками не прописывал и откуда взялась не знаю, поэтому удалять не буду - лучшее враг хорошего.
Skyworker вне форума   Ответить с цитированием
Старый 22.01.2016, 10:00 Вверх   #39
leshiy_odessa
Частый пользователь
 
Сообщений: 575
Репутация: 51
По умолчанию

Цитата:
Сообщение от Skyworker Посмотреть сообщение

А вот DHCP Option 121 и DHCP Option 249. - я этого не понимаю.
Да забейте. Я это всё для саморазвития. Просто есть разные "способы" получения маршрутов по DHCP. DHCP Option — 33, DHCP Option — 121, DHCP Option — 249. Я спрашивал у ТЕНЕТа, они ответили что поддерживают последние две.

Вообще там еще куча всяких таких тонких настроек, но смысла в них, если всё работает, ноль.
leshiy_odessa вне форума   Ответить с цитированием
Старый 22.01.2016, 11:42 Вверх   #40
Skyworker
Пользователь
 
Сообщений: 32
Репутация: 14
По умолчанию

А вот такой вопрос относительно
Код:
config phyint
    option network wlan0
    option direction disabled
В этом конфиге прописываются интерфейсы определённые в uci. Интерфейс wlan0 определён в самой системе, т.е. его так можно увидеть вызвав команду ifconfig, а в системе uci он именуется как radio0. Тогда может быть правильно было бы его прописать в этом конфиге как radio0 ? Это значит раз. А второе, это то, что wifi бриджем подключен к четырем сетевым портам и следовательно когда multicast пойдет на какой-то один из сетевых портов, он тут же пойдет и на остальные порты, в том числе и на wifi.

Когда-то я собрал из старого железа роутер, так как понял, что мой dir-300 rev1 очень сильно режет скорость, а на прямую интернет просто летает. Всё это на Vyatta работало. Так там мне пришлось wifi в отдельную сеть вывести, чтобы по проводам мог ходить multicast. Т.е. wifi 192.168.0.0/24 lan 192.168.1.0/24

Так что я сомневаюсь в том, что указанное выше отключение wlan0 в конфиге igmpproxy сработает. wifi надо выводить из бриджа в отдельную сеть и потом на нём DHCP отдельно настроить.
Skyworker вне форума   Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход


Часовой пояс GMT +2, время: 03:42.


Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.